idea创建springboot项目javaversion只能选择17和21怎么办

后端 潘老师 3个月前 (12-06) 192 ℃ (0) 扫码查看

本文主要讲解关于idea创建springboot项目javaversion只能选择17和21怎么办相关内容,让我们来一起了解下吧!

首先说下原因,根据官网所说,以后jdk版本主流为17,而且在2023年11月24日,3.0以下的版本不再支持了,升级为17后大部分用户需要修改import相关API的时候,要用jakarta替换javax。比如:原来引入javax.servlet.Filter的地方,需要替换为jakarta.servlet.Filter

再说解决办法,网上查到的解决办法有两种,一种是创建SpringBoot时,把https://start.spring.io/或者http://start.springboot.io/替换为 https://start.aliyun.com/

这个我试了一下,发现报错,就没在深入试了

第二个办法就是升级到17。

最后我试了下创建SpringBoot项目时就使用17创建,创建完后进入pom文件,修改版本号,我的pom文件如下

<?xml version="1.0" encoding="UTF-8"?>
<project xmlns="http://maven.apache.org/POM/4.0.0" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
         xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 https://maven.apache.org/xsd/maven-4.0.0.xsd">
    <modelVersion>4.0.0</modelVersion>
    <parent>
        <groupId>org.springframework.boot</groupId>
        <artifactId>spring-boot-starter-parent</artifactId>
        <version>2.7.17</version>
        <relativePath/> <!-- lookup parent from repository -->
    </parent>
    <groupId>com.testvesion</groupId>
    <artifactId>testvesion</artifactId>
    <version>0.0.1-SNAPSHOT</version>
    <name>testvesion</name>
    <description>Demo project for Spring Boot</description>
    <properties>
        <java.version>1.8</java.version>
    </properties>
    <dependencies>
        <dependency>
            <groupId>org.springframework.boot</groupId>
            <artifactId>spring-boot-starter-web</artifactId>
        </dependency>

        <dependency>
            <groupId>org.projectlombok</groupId>
            <artifactId>lombok</artifactId>
            <optional>true</optional>
        </dependency>
        <dependency>
            <groupId>org.springframework.boot</groupId>
            <artifactId>spring-boot-starter-test</artifactId>
            <scope>test</scope>
        </dependency>
    </dependencies>

    <build>
        <plugins>
            <plugin>
                <groupId>org.springframework.boot</groupId>
                <artifactId>spring-boot-maven-plugin</artifactId>
                <configuration>
                    <excludes>
                        <exclude>
                            <groupId>org.projectlombok</groupId>
                            <artifactId>lombok</artifactId>
                        </exclude>
                    </excludes>
                </configuration>
            </plugin>
        </plugins>
    </build>

</project>

之后就可以运行了。

大家如果有别的解决办法,希望评论区留下解决办法

好啦,以上就是关于idea创建springboot项目javaversion只能选择17和21怎么办相关的全部内容,希望对你有帮助。欢迎持续关注潘子夜个人博客(www.panziye.com),学习愉快哦!


版权声明:本站文章,如无说明,均为本站原创,转载请注明文章来源。如有侵权,请联系博主删除。
本文链接:https://www.panziye.com/back/12182.html
喜欢 (0)
请潘老师喝杯Coffee吧!】
分享 (0)
用户头像
发表我的评论
取消评论
表情 贴图 签到 代码

Hi,您需要填写昵称和邮箱!

  • 昵称【必填】
  • 邮箱【必填】
  • 网址【可选】